Hippo Add-ons

classic Classic list List threaded Threaded
20 messages Options
Reply | Threaded
Open this post in threaded view
|

Hippo Add-ons

shrey.khandelwal
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: Hippo Add-ons

Adolfo Benedetti
Hi Shrey Khandelwal,

In Hippo you can find certified plugins[1] and/or community plugins[2].
So, e.g. if you want to install the tagging addon, you should follow
the instructions on the forge addon page[3].

[1]https://wiki.onehippo.com/display/CMS7/Hippo+Certified+Plugins
[2]https://forge.onehippo.org/gf/
[3]http://ecm-tagging.forge.onehippo.org/install.html

Cheers,

Adolfo
--
Adolfo Benedetti



2012/2/21 shrey.khandelwal <[hidden email]>:
> tagging
_______________________________________________
Hippo-cms7-user mailing list and forums
http://www.onehippo.org/cms7/support/forums.html
Reply | Threaded
Open this post in threaded view
|

Re: Hippo Add-ons

shrey.khandelwal
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: Hippo Add-ons

Steven Grijzenhout
Hi Shrey,

Your repository is probably stored in your target folder and deleted
when doing a clean install. Try this:

Use the option -Drepo.path=/some/path/to/repository during start up.
This will avoid your repository to be cleared when you do a mvn clean.

For example start your project with:
$ mvn -P cargo.run -Drepo.path=/home/usr/tmp/repo

or with jrebel:
$ mvn -P cargo.run -Drepo.path=/home/usr/tmp/repo -Djrebel

Regards,

Steven


On Tue, Feb 21, 2012 at 9:40 AM, shrey.khandelwal
<[hidden email]> wrote:

>
> Dear adolfo,
>
> I tried that for polls, but what is happening is that when i configure my
> cms pom.xml and try to clean build my cms. the rest api configurations that
> i have done for my rest api goes. Also the content that i have added remains
> no longer available...
>
> Also, I see that there are svn links available through which i can download
> the whole code of the project. What if i want to have the code so that i can
> customize it according to the requirements that i have ?
>
> Thanks and Regards,
> Shrey Khandelwal
>
> --
> View this message in context: http://hippo.2275632.n2.nabble.com/Hippo-Add-ons-tp7303626p7303979.html
> Sent from the Hippo CMS 7 mailing list archive at Nabble.com.
> _______________________________________________
> Hippo-cms7-user mailing list and forums
> http://www.onehippo.org/cms7/support/forums.html
_______________________________________________
Hippo-cms7-user mailing list and forums
http://www.onehippo.org/cms7/support/forums.html
Reply | Threaded
Open this post in threaded view
|

Re: Hippo Add-ons

shrey.khandelwal
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: Hippo Add-ons

Steven Grijzenhout
Hi Shrey,

Did you use the same -Drepo.path location before and after your mvn
clean? For example:

$ mvn -P cargo.run -Drepo.path=/home/usr/tmp/repo
[make your changes]
$ mvn clean install
$ mvn -P cargo.run -Drepo.path=/home/usr/tmp/repo


On Tue, Feb 21, 2012 at 1:41 PM, shrey.khandelwal
<[hidden email]> wrote:

> Dear Steven,
>
> I tried using -Drepo.path thing as you suggested but still the problem
> remained the same.
>
> Thanks and Regards,
> Shrey Khandelwal
>
> --
> View this message in context: http://hippo.2275632.n2.nabble.com/Hippo-Add-ons-tp7303626p7304586.html
> Sent from the Hippo CMS 7 mailing list archive at Nabble.com.
> _______________________________________________
> Hippo-cms7-user mailing list and forums
> http://www.onehippo.org/cms7/support/forums.html
_______________________________________________
Hippo-cms7-user mailing list and forums
http://www.onehippo.org/cms7/support/forums.html
Reply | Threaded
Open this post in threaded view
|

Re: Hippo Add-ons

shrey.khandelwal
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: Hippo Add-ons

Jasha Joachimsthal
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: Hippo Add-ons

shrey.khandelwal
This post was updated on .
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: Hippo Add-ons

Steven Grijzenhout
Hi Shrey,

Did you add these dependencies to your SITE APPLICATIONS pom.xml (so
not your root pom)?

<dependency>
  <groupId>org.apache.geronimo.specs</groupId>
  <artifactId>geronimo-annotation_1.1_spec</artifactId>
  <version>1.0.1</version>
  <!-- NOTE: You should use 'provided' instead of 'compile'
       when your application container provides
javax.annotation.security package. -->
  <scope>compile</scope>
</dependency>


<dependency>
  <groupId>org.onehippo.cms7.hst.components</groupId>
  <artifactId>hst-jaxrs</artifactId>
  <version>${hippo.hst.version}</version>
</dependency>


On Wed, Feb 22, 2012 at 7:32 AM, shrey.khandelwal
<[hidden email]> wrote:

> Dear Jasha,
>
> Can you please tell me which dependency am i missing? and how should i
> update that?  I followed and rechecked the documents shared by jeroen. I am
> sorry but am not able to locate any dependency that i am missing. Let me
> know if you need any more file/log for verification
>
> thanks and regards,
> Shrey Khandelwal
>
> --
> View this message in context: http://hippo.2275632.n2.nabble.com/Hippo-Add-ons-tp7303626p7307429.html
> Sent from the Hippo CMS 7 mailing list archive at Nabble.com.
> _______________________________________________
> Hippo-cms7-user mailing list and forums
> http://www.onehippo.org/cms7/support/forums.html
_______________________________________________
Hippo-cms7-user mailing list and forums
http://www.onehippo.org/cms7/support/forums.html
Reply | Threaded
Open this post in threaded view
|

Re: Hippo Add-ons

shrey.khandelwal
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: Hippo Add-ons

Woonsan Ko-3
Hi Shrey,

org.hippoecm.hst.jaxrs.cxf.QueryStringReplacingInterceptor has been added with the following issue, which means it is available from HST-2.22.07 or later. Can you check your HST-2 version?

https://issues.onehippo.com/browse/HSTTWO-1848

Regards,

Woonsan

On 02/22/2012 04:13 AM, shrey.khandelwal wrote:

> yes i have added these dependencies to my site pom.xml and not in my root
> pom.xml.
>
> thanks and regards,
> shrey khandelwal
>
> --
> View this message in context: http://hippo.2275632.n2.nabble.com/Hippo-Add-ons-tp7303626p7307711.html
> Sent from the Hippo CMS 7 mailing list archive at Nabble.com.
> _______________________________________________
> Hippo-cms7-user mailing list and forums
> http://www.onehippo.org/cms7/support/forums.html


--
[hidden email]     www.onehippo.com
Boston - 1 Broadway, Cambridge, MA 02142
Amsterdam - Oosteinde 11, 1017 WT Amsterdam
US +1 877 414 4776 (toll free)
Europe +31(0)20 522 4466

_______________________________________________
Hippo-cms7-user mailing list and forums
http://www.onehippo.org/cms7/support/forums.html
Reply | Threaded
Open this post in threaded view
|

Re: Hippo Add-ons

shrey.khandelwal
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: Hippo Add-ons

Woonsan Ko-3
Hi Shrey,

So, you are using 2.22.06 according to your dependency tree output.
Please upgrade it to the newest version of 2.22.xx such as 2.22.10.
You may add the following property in the root pom.xml of your project:

  <properties>
    <!-- SNIP -->
    <hippo.hst.version>2.22.10</hippo.hst.version>
    <!-- SNIP -->
  </properties>

Regards,

Woonsan


On 02/23/2012 01:10 AM, shrey.khandelwal wrote:

> Dear Woonsan,
>
> I am using HST HST 2.22.xx.
>
> http://hippo.2275632.n2.nabble.com/file/n7310966/mvn_dependency-tree.txt
> mvn_dependency-tree.txt
>
> Please find the mvn dependency:tree output file.
>
> Thanks and Regards,
>
> Shrey Khandelwal
>
> --
> View this message in context: http://hippo.2275632.n2.nabble.com/Hippo-Add-ons-tp7303626p7310966.html
> Sent from the Hippo CMS 7 mailing list archive at Nabble.com.
> _______________________________________________
> Hippo-cms7-user mailing list and forums
> http://www.onehippo.org/cms7/support/forums.html


--
[hidden email]     www.onehippo.com
Boston - 1 Broadway, Cambridge, MA 02142
Amsterdam - Oosteinde 11, 1017 WT Amsterdam
US +1 877 414 4776 (toll free)
Europe +31(0)20 522 4466

_______________________________________________
Hippo-cms7-user mailing list and forums
http://www.onehippo.org/cms7/support/forums.html
Reply | Threaded
Open this post in threaded view
|

Re: Hippo Add-ons

shrey.khandelwal
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: Hippo Add-ons

shrey.khandelwal
This post was updated on .
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: Hippo Add-ons

Woonsan Ko-3
Hi Shrey,

So, do you see other error logs?
Or do you still see the ClassNotFoundException on
QueryStringReplacingInterceptor?

Regards,

Woonsan


On 02/23/2012 02:07 AM, shrey.khandelwal wrote:

> Dear Woonsan,
>
> I updated the hst dependency in my main pom.xml as you suggested and did
> clean install on the project. Of no use. Still after rebuilding my project
> and restarting the content in the cms is not available.
>
> thanks and regards,
> shrey khandelwal
>
> --
> View this message in context: http://hippo.2275632.n2.nabble.com/Hippo-Add-ons-tp7303626p7311029.html
> Sent from the Hippo CMS 7 mailing list archive at Nabble.com.
> _______________________________________________
> Hippo-cms7-user mailing list and forums
> http://www.onehippo.org/cms7/support/forums.html


--
[hidden email]     www.onehippo.com
Boston - 1 Broadway, Cambridge, MA 02142
Amsterdam - Oosteinde 11, 1017 WT Amsterdam
US +1 877 414 4776 (toll free)
Europe +31(0)20 522 4466

_______________________________________________
Hippo-cms7-user mailing list and forums
http://www.onehippo.org/cms7/support/forums.html
Reply | Threaded
Open this post in threaded view
|

Re: Hippo Add-ons

shrey.khandelwal
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: Hippo Add-ons

Woonsan Ko-3
On 02/24/2012 02:08 AM, shrey.khandelwal wrote:
> Dear Woonsan,
>
> I dont think i got QueryStringReplacingInterceptor ClassNotFoundException
> Exeption again. The error log that i had attched in the previous message is
> the error that i am getting now.
If you mean the following attachment, I can't see any other exceptions
there:
http://hippo.2275632.n2.nabble.com/file/n7307354/error_log.txt

>
> I am also attching the startup log with this message.
>
> http://hippo.2275632.n2.nabble.com/file/n7314101/startup.txt.txt
> startup.txt.txt
So, the only problem you have now is that you cannot use an external
repository storage path so you lose contents after restarting. Right?
I saw you run the command, 'mvn -P cargo.run
-Drepo.path=C:\hippo_cms\UsingMaven3\back' in the startup.txt.txt file.
Can you check if the directory has sub directories such as 'repository',
'version', and 'workspaces'?

Regards,

Woonsan

>
> thanks and regards,
> shrey khandelwal
>
> --
> View this message in context: http://hippo.2275632.n2.nabble.com/Hippo-Add-ons-tp7303626p7314101.html
> Sent from the Hippo CMS 7 mailing list archive at Nabble.com.
> _______________________________________________
> Hippo-cms7-user mailing list and forums
> http://www.onehippo.org/cms7/support/forums.html


--
[hidden email]     www.onehippo.com
Boston - 1 Broadway, Cambridge, MA 02142
Amsterdam - Oosteinde 11, 1017 WT Amsterdam
US +1 877 414 4776 (toll free)
Europe +31(0)20 522 4466

_______________________________________________
Hippo-cms7-user mailing list and forums
http://www.onehippo.org/cms7/support/forums.html
Reply | Threaded
Open this post in threaded view
|

Re: Hippo Add-ons

shrey.khandelwal
CONTENTS DELETED
The author has deleted this message.