Related Docs Plugin is not working..

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Related Docs Plugin is not working..

lincstar1
Hello All,

I am using Hippo CMS 7.6 version and I have configured Related docs plugin from this url http://relateddocs.forge.onehippo.org/install.html I configured upto "Adding related docs to your template" section but I need to add those template but I dont know where to add them So i added them under hippo:configuration/hippo:frontend/cms/cms-relayteddocsproviders" node. Please correct me If i am wrong.

After all this I did the clean install on my project then it is giving me following error:


Caused by: java.lang.NullPointerException
  at org.onehippo.forge.relateddocs.editor.RelatedDocsPlugin.<init>(RelatedDocsPlugin.java:81)

Caused by: java.lang.NullPointerException
  at org.onehippo.forge.relateddocs.editor.RelatedDocsSuugestPlugin.<init>(RelatedDocsSuugestPlugin.java:81)


If anyone have any idea Please do reply here..
Waiting for your reply.


Thank you,
LincStar
Reply | Threaded
Open this post in threaded view
|

Re: Related Docs Plugin is not working..

William Borg Barthet
Hi LincStar,

that is not the right place to add this configuration. You should add it under the editor template of the document type you want the related docs field to appear in. So if you have, for example, a textdocument where you want to have the relateddocs, you should put this configuration under /hippo:namespaces/myhippoproject/textdocument/editor:templates/_default_

I hope this helps

William


On 7 February 2013 13:52, lincstar1 <[hidden email]> wrote:
Hello All,

I am using Hippo CMS 7.6 version and I have configured Related docs plugin
from this url http://relateddocs.forge.onehippo.org/install.html I
configured upto "Adding related docs to your template" section but I need to
add those template but I dont know where to add them So i added them under
hippo:configuration/hippo:frontend/cms/cms-relayteddocsproviders" node.
Please correct me If i am wrong.

After all this I did the clean install on my project then it is giving me
following error:


Caused by: java.lang.NullPointerException
  at
org.onehippo.forge.relateddocs.editor.RelatedDocsPlugin.<init>(RelatedDocsPlugin.java:81)

Caused by: java.lang.NullPointerException
  at
org.onehippo.forge.relateddocs.editor.RelatedDocsSuugestPlugin.<init>(RelatedDocsSuugestPlugin.java:81)


If anyone have any idea Please do reply here..
Waiting for your reply.


Thank you,
LincStar



--
View this message in context: http://hippo.2275632.n2.nabble.com/Related-Docs-Plugin-is-not-working-tp7580379.html
Sent from the Hippo CMS 7 mailing list archive at Nabble.com.
_______________________________________________
Hippo-cms7-user mailing list and forums
http://www.onehippo.org/cms7/support/forums.html



--
Amsterdam - Oosteinde 11, 1017 WT Amsterdam
Boston - 1 Broadway, Cambridge, MA 02142

US +1 877 414 4776 (toll free)
Europe +31(0)20 522 4466
www.onehippo.com

_______________________________________________
Hippo-cms7-user mailing list and forums
http://www.onehippo.org/cms7/support/forums.html