.RepositoryNotAvailableException for '/site/': 'org.hippoecm.hst.core.container.

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

.RepositoryNotAvailableException for '/site/': 'org.hippoecm.hst.core.container.

abhishek bhardwaj
Hi all I am facing following problem while running project on my machine. due to this cms and cms/consolo are working but /site is not working ...... it shows http 500 error. i am attaching to you following snaps. es\Apache Software Foundation\apache-maven-3.0.4\bin [WARNING] [talledLocalContainer] Feb 14, 2013 4:19:15 PM org.apache.coyote.http11.Http11Protocol init [WARNING] [talledLocalContainer] INFO: Initializing Coyote HTTP/1.1 on http-8080 [WARNING] [talledLocalContainer] Feb 14, 2013 4:19:15 PM org.apache.catalina.startup.Catalina load [WARNING] [talledLocalContainer] INFO: Initialization processed in 965 ms [WARNING] [talledLocalContainer] Feb 14, 2013 4:19:15 PM org.apache.catalina.core.StandardService start [WARNING] [talledLocalContainer] INFO: Starting service Catalina [WARNING] [talledLocalContainer] Feb 14, 2013 4:19:15 PM org.apache.catalina.core.StandardEngine start [WARNING] [talledLocalContainer] INFO: Starting Servlet Engine: Apache Tomcat/6.0.35 [WARNING] [talledLocalContainer] Feb 14, 2013 4:19:16 PM org.apache.catalina.startup.HostConfig deployWAR [WARNING] [talledLocalContainer] INFO: Deploying web application archive cargocpc.war [WARNING] [talledLocalContainer] Feb 14, 2013 4:19:16 PM org.apache.catalina.startup.HostConfig deployWAR [WARNING] [talledLocalContainer] INFO: Deploying web application archive cms.war [INFO] [talledLocalContainer] 14.02.2013 16:19:57 INFO [org.hippoecm.repository.updater.UpdaterEngine.migrate():629] no migration cycle because clean repository startup without hippo configuration [WARNING] [talledLocalContainer] Feb 14, 2013 4:20:26 PM org.apache.catalina.startup.HostConfig deployWAR [WARNING] [talledLocalContainer] INFO: Deploying web application archive site.war [WARNING] [talledLocalContainer] Feb 14, 2013 4:20:26 PM org.apache.catalina.realm.JAASRealm setUseContextClassLoader [WARNING] [talledLocalContainer] INFO: Setting useContextClassLoader = true [WARNING] [talledLocalContainer] Feb 14, 2013 4:20:36 PM org.apache.catalina.startup.HostConfig deployDirectory [WARNING] [talledLocalContainer] INFO: Deploying web application directory host-manager [WARNING] [talledLocalContainer] Feb 14, 2013 4:20:36 PM org.apache.catalina.startup.HostConfig deployDirectory [WARNING] [talledLocalContainer] INFO: Deploying web application directory manager [WARNING] [talledLocalContainer] Feb 14, 2013 4:20:36 PM org.apache.coyote.http11.Http11Protocol start [WARNING] [talledLocalContainer] INFO: Starting Coyote HTTP/1.1 on http-8080 [WARNING] [talledLocalContainer] Feb 14, 2013 4:20:36 PM org.apache.jk.common.ChannelSocket init [WARNING] [talledLocalContainer] INFO: JK: ajp13 listening on /0.0.0.0:8009 [WARNING] [talledLocalContainer] Feb 14, 2013 4:20:36 PM org.apache.jk.server.JkMain start [WARNING] [talledLocalContainer] INFO: Jk running ID=0 time=0/42 config=null [WARNING] [talledLocalContainer] Feb 14, 2013 4:20:36 PM org.apache.catalina.startup.Catalina start [WARNING] [talledLocalContainer] INFO: Server startup in 80814 ms [INFO] [talledLocalContainer] Tomcat 6.x started on port [8080] [INFO] Press Ctrl-C to stop the container... [INFO] [talledLocalContainer] 14.02.2013 16:20:57 WARN [org.hippoecm.hst.container.HstFilter.doFilter():435] org.hippoe cm.hst.core.container.RepositoryNotAvailableException for '/site/': 'org.hippoecm.hst.core.container.RepositoryNotAvaila bleException: Exception during loading configuration nodes. '
Reply | Threaded
Open this post in threaded view
|

Re: .RepositoryNotAvailableException for '/site/': 'org.hippoecm.hst.core.container.

Jeroen Reijn
Administrator
Well it says "Exception during loading configuration nodes", so I
guess you will need to check our HST configuration. Does it give more
hints in the hippo-site.log?

On Thu, Feb 14, 2013 at 12:15 PM, abhishek bhardwaj
<[hidden email]> wrote:

> Hi allI am facing following problem while running  project on my machine.due
> to this cms and cms/consolo are working but /site is not working ......it
> shows http 500 error.i am attaching to you following snaps.es\Apache
> Software Foundation\apache-maven-3.0.4\bin[WARNING] [talledLocalContainer]
> Feb 14, 2013 4:19:15 PM org.apache.coyote.http11.Http11Protocol
> init[WARNING] [talledLocalContainer] INFO: Initializing Coyote HTTP/1.1 on
> http-8080[WARNING] [talledLocalContainer] Feb 14, 2013 4:19:15 PM
> org.apache.catalina.startup.Catalina load[WARNING] [talledLocalContainer]
> INFO: Initialization processed in 965 ms[WARNING] [talledLocalContainer] Feb
> 14, 2013 4:19:15 PM org.apache.catalina.core.StandardService start[WARNING]
> [talledLocalContainer] INFO: Starting service Catalina[WARNING]
> [talledLocalContainer] Feb 14, 2013 4:19:15 PM
> org.apache.catalina.core.StandardEngine start[WARNING]
> [talledLocalContainer] INFO: Starting Servlet Engine: Apache
> Tomcat/6.0.35[WARNING] [talledLocalContainer] Feb 14, 2013 4:19:16 PM
> org.apache.catalina.startup.HostConfig deployWAR[WARNING]
> [talledLocalContainer] INFO: Deploying web application archive
> cargocpc.war[WARNING] [talledLocalContainer] Feb 14, 2013 4:19:16 PM
> org.apache.catalina.startup.HostConfig deployWAR[WARNING]
> [talledLocalContainer] INFO: Deploying web application archive cms.war[INFO]
> [talledLocalContainer] 14.02.2013 16:19:57 INFO
> [org.hippoecm.repository.updater.UpdaterEngine.migrate():629] no migration
> cycle because clean repository startup without hippo configuration[WARNING]
> [talledLocalContainer] Feb 14, 2013 4:20:26 PM
> org.apache.catalina.startup.HostConfig deployWAR[WARNING]
> [talledLocalContainer] INFO: Deploying web application archive
> site.war[WARNING] [talledLocalContainer] Feb 14, 2013 4:20:26 PM
> org.apache.catalina.realm.JAASRealm setUseContextClassLoader[WARNING]
> [talledLocalContainer] INFO: Setting useContextClassLoader = true[WARNING]
> [talledLocalContainer] Feb 14, 2013 4:20:36 PM
> org.apache.catalina.startup.HostConfig deployDirectory[WARNING]
> [talledLocalContainer] INFO: Deploying web application directory
> host-manager[WARNING] [talledLocalContainer] Feb 14, 2013 4:20:36 PM
> org.apache.catalina.startup.HostConfig deployDirectory[WARNING]
> [talledLocalContainer] INFO: Deploying web application directory
> manager[WARNING] [talledLocalContainer] Feb 14, 2013 4:20:36 PM
> org.apache.coyote.http11.Http11Protocol start[WARNING]
> [talledLocalContainer] INFO: Starting Coyote HTTP/1.1 on http-8080[WARNING]
> [talledLocalContainer] Feb 14, 2013 4:20:36 PM
> org.apache.jk.common.ChannelSocket init[WARNING] [talledLocalContainer]
> INFO: JK: ajp13 listening on /0.0.0.0:8009[WARNING] [talledLocalContainer]
> Feb 14, 2013 4:20:36 PM org.apache.jk.server.JkMain start[WARNING]
> [talledLocalContainer] INFO: Jk running ID=0 time=0/42  config=null[WARNING]
> [talledLocalContainer] Feb 14, 2013 4:20:36 PM
> org.apache.catalina.startup.Catalina start[WARNING] [talledLocalContainer]
> INFO: Server startup in 80814 ms[INFO] [talledLocalContainer] Tomcat 6.x
> started on port [8080][INFO] Press Ctrl-C to stop the container...[INFO]
> [talledLocalContainer] 14.02.2013 16:20:57 WARN
> [org.hippoecm.hst.container.HstFilter.doFilter():435]
> org.hippoecm.hst.core.container.RepositoryNotAvailableException for
> '/site/': 'org.hippoecm.hst.core.container.RepositoryNotAvailableException:
> Exception during loading configuration nodes. '
>
>
>
> --
> View this message in context: http://hippo.2275632.n2.nabble.com/RepositoryNotAvailableException-for-site-org-hippoecm-hst-core-container-tp7580435.html
> Sent from the Hippo CMS 7 mailing list archive at Nabble.com.
> _______________________________________________
> Hippo-cms7-user mailing list and forums
> http://www.onehippo.org/cms7/support/forums.html



--
Jeroen Reijn
Solution Architect
Hippo

Amsterdam - Oosteinde 11, 1017 WT Amsterdam
Boston - 1 Broadway, Cambridge, MA 02142

US +1 877 414 4776 (toll free)
Europe +31(0)20 522 4466
www.onehippo.com

http://about.me/jeroenreijn
_______________________________________________
Hippo-cms7-user mailing list and forums
http://www.onehippo.org/cms7/support/forums.html
Ard
Reply | Threaded
Open this post in threaded view
|

Re: .RepositoryNotAvailableException for '/site/': 'org.hippoecm.hst.core.container.

Ard
in the 7.7 the RepositoryNotAvailableExcepton can be a bit confusing :
In the 7.8 we have dropped this exception altogether.

You get the RepositoryNotAvailableExcepton when the hstconfiguser
cannot login into the repository. In the 7.8 you see a clean warning
about a login exception.

Either way, check your users/passwords in the hst-config,properties to
be correct

Regards Ard

On Thu, Feb 14, 2013 at 1:10 PM, Jeroen Reijn <[hidden email]> wrote:

> Well it says "Exception during loading configuration nodes", so I
> guess you will need to check our HST configuration. Does it give more
> hints in the hippo-site.log?
>
> On Thu, Feb 14, 2013 at 12:15 PM, abhishek bhardwaj
> <[hidden email]> wrote:
>> Hi allI am facing following problem while running  project on my machine.due
>> to this cms and cms/consolo are working but /site is not working ......it
>> shows http 500 error.i am attaching to you following snaps.es\Apache
>> Software Foundation\apache-maven-3.0.4\bin[WARNING] [talledLocalContainer]
>> Feb 14, 2013 4:19:15 PM org.apache.coyote.http11.Http11Protocol
>> init[WARNING] [talledLocalContainer] INFO: Initializing Coyote HTTP/1.1 on
>> http-8080[WARNING] [talledLocalContainer] Feb 14, 2013 4:19:15 PM
>> org.apache.catalina.startup.Catalina load[WARNING] [talledLocalContainer]
>> INFO: Initialization processed in 965 ms[WARNING] [talledLocalContainer] Feb
>> 14, 2013 4:19:15 PM org.apache.catalina.core.StandardService start[WARNING]
>> [talledLocalContainer] INFO: Starting service Catalina[WARNING]
>> [talledLocalContainer] Feb 14, 2013 4:19:15 PM
>> org.apache.catalina.core.StandardEngine start[WARNING]
>> [talledLocalContainer] INFO: Starting Servlet Engine: Apache
>> Tomcat/6.0.35[WARNING] [talledLocalContainer] Feb 14, 2013 4:19:16 PM
>> org.apache.catalina.startup.HostConfig deployWAR[WARNING]
>> [talledLocalContainer] INFO: Deploying web application archive
>> cargocpc.war[WARNING] [talledLocalContainer] Feb 14, 2013 4:19:16 PM
>> org.apache.catalina.startup.HostConfig deployWAR[WARNING]
>> [talledLocalContainer] INFO: Deploying web application archive cms.war[INFO]
>> [talledLocalContainer] 14.02.2013 16:19:57 INFO
>> [org.hippoecm.repository.updater.UpdaterEngine.migrate():629] no migration
>> cycle because clean repository startup without hippo configuration[WARNING]
>> [talledLocalContainer] Feb 14, 2013 4:20:26 PM
>> org.apache.catalina.startup.HostConfig deployWAR[WARNING]
>> [talledLocalContainer] INFO: Deploying web application archive
>> site.war[WARNING] [talledLocalContainer] Feb 14, 2013 4:20:26 PM
>> org.apache.catalina.realm.JAASRealm setUseContextClassLoader[WARNING]
>> [talledLocalContainer] INFO: Setting useContextClassLoader = true[WARNING]
>> [talledLocalContainer] Feb 14, 2013 4:20:36 PM
>> org.apache.catalina.startup.HostConfig deployDirectory[WARNING]
>> [talledLocalContainer] INFO: Deploying web application directory
>> host-manager[WARNING] [talledLocalContainer] Feb 14, 2013 4:20:36 PM
>> org.apache.catalina.startup.HostConfig deployDirectory[WARNING]
>> [talledLocalContainer] INFO: Deploying web application directory
>> manager[WARNING] [talledLocalContainer] Feb 14, 2013 4:20:36 PM
>> org.apache.coyote.http11.Http11Protocol start[WARNING]
>> [talledLocalContainer] INFO: Starting Coyote HTTP/1.1 on http-8080[WARNING]
>> [talledLocalContainer] Feb 14, 2013 4:20:36 PM
>> org.apache.jk.common.ChannelSocket init[WARNING] [talledLocalContainer]
>> INFO: JK: ajp13 listening on /0.0.0.0:8009[WARNING] [talledLocalContainer]
>> Feb 14, 2013 4:20:36 PM org.apache.jk.server.JkMain start[WARNING]
>> [talledLocalContainer] INFO: Jk running ID=0 time=0/42  config=null[WARNING]
>> [talledLocalContainer] Feb 14, 2013 4:20:36 PM
>> org.apache.catalina.startup.Catalina start[WARNING] [talledLocalContainer]
>> INFO: Server startup in 80814 ms[INFO] [talledLocalContainer] Tomcat 6.x
>> started on port [8080][INFO] Press Ctrl-C to stop the container...[INFO]
>> [talledLocalContainer] 14.02.2013 16:20:57 WARN
>> [org.hippoecm.hst.container.HstFilter.doFilter():435]
>> org.hippoecm.hst.core.container.RepositoryNotAvailableException for
>> '/site/': 'org.hippoecm.hst.core.container.RepositoryNotAvailableException:
>> Exception during loading configuration nodes. '
>>
>>
>>
>> --
>> View this message in context: http://hippo.2275632.n2.nabble.com/RepositoryNotAvailableException-for-site-org-hippoecm-hst-core-container-tp7580435.html
>> Sent from the Hippo CMS 7 mailing list archive at Nabble.com.
>> _______________________________________________
>> Hippo-cms7-user mailing list and forums
>> http://www.onehippo.org/cms7/support/forums.html
>
>
>
> --
> Jeroen Reijn
> Solution Architect
> Hippo
>
> Amsterdam - Oosteinde 11, 1017 WT Amsterdam
> Boston - 1 Broadway, Cambridge, MA 02142
>
> US +1 877 414 4776 (toll free)
> Europe +31(0)20 522 4466
> www.onehippo.com
>
> http://about.me/jeroenreijn
> _______________________________________________
> Hippo-cms7-user mailing list and forums
> http://www.onehippo.org/cms7/support/forums.html



--
Amsterdam - Oosteinde 11, 1017 WT Amsterdam
Boston - 1 Broadway, Cambridge, MA 02142

US +1 877 414 4776 (toll free)
Europe +31(0)20 522 4466
www.onehippo.com
_______________________________________________
Hippo-cms7-user mailing list and forums
http://www.onehippo.org/cms7/support/forums.html
Reply | Threaded
Open this post in threaded view
|

Re: .RepositoryNotAvailableException for '/site/': 'org.hippoecm.hst.core.container.

abhishek bhardwaj
Hi all,

I tried according to above solutions but still problem is not fix.
/cms is working
/cms/console is working
but /site is not going to open showing http 500 error.....



On Thu, Feb 14, 2013 at 6:01 PM, Ard [via Hippo]
<[hidden email]> wrote:

> in the 7.7 the RepositoryNotAvailableExcepton can be a bit confusing :
> In the 7.8 we have dropped this exception altogether.
>
> You get the RepositoryNotAvailableExcepton when the hstconfiguser
> cannot login into the repository. In the 7.8 you see a clean warning
> about a login exception.
>
> Either way, check your users/passwords in the hst-config,properties to
> be correct
>
> Regards Ard
>
> On Thu, Feb 14, 2013 at 1:10 PM, Jeroen Reijn <[hidden email]> wrote:
>
>> Well it says "Exception during loading configuration nodes", so I
>> guess you will need to check our HST configuration. Does it give more
>> hints in the hippo-site.log?
>>
>> On Thu, Feb 14, 2013 at 12:15 PM, abhishek bhardwaj
>> <[hidden email]> wrote:
>>> Hi allI am facing following problem while running  project on my
>>> machine.due
>>> to this cms and cms/consolo are working but /site is not working ......it
>>> shows http 500 error.i am attaching to you following snaps.es\Apache
>>> Software Foundation\apache-maven-3.0.4\bin[WARNING]
>>> [talledLocalContainer]
>>> Feb 14, 2013 4:19:15 PM org.apache.coyote.http11.Http11Protocol
>>> init[WARNING] [talledLocalContainer] INFO: Initializing Coyote HTTP/1.1
>>> on
>>> http-8080[WARNING] [talledLocalContainer] Feb 14, 2013 4:19:15 PM
>>> org.apache.catalina.startup.Catalina load[WARNING] [talledLocalContainer]
>>> INFO: Initialization processed in 965 ms[WARNING] [talledLocalContainer]
>>> Feb
>>> 14, 2013 4:19:15 PM org.apache.catalina.core.StandardService
>>> start[WARNING]
>>> [talledLocalContainer] INFO: Starting service Catalina[WARNING]
>>> [talledLocalContainer] Feb 14, 2013 4:19:15 PM
>>> org.apache.catalina.core.StandardEngine start[WARNING]
>>> [talledLocalContainer] INFO: Starting Servlet Engine: Apache
>>> Tomcat/6.0.35[WARNING] [talledLocalContainer] Feb 14, 2013 4:19:16 PM
>>> org.apache.catalina.startup.HostConfig deployWAR[WARNING]
>>> [talledLocalContainer] INFO: Deploying web application archive
>>> cargocpc.war[WARNING] [talledLocalContainer] Feb 14, 2013 4:19:16 PM
>>> org.apache.catalina.startup.HostConfig deployWAR[WARNING]
>>> [talledLocalContainer] INFO: Deploying web application archive
>>> cms.war[INFO]
>>> [talledLocalContainer] 14.02.2013 16:19:57 INFO
>>> [org.hippoecm.repository.updater.UpdaterEngine.migrate():629] no
>>> migration
>>> cycle because clean repository startup without hippo
>>> configuration[WARNING]
>>> [talledLocalContainer] Feb 14, 2013 4:20:26 PM
>>> org.apache.catalina.startup.HostConfig deployWAR[WARNING]
>>> [talledLocalContainer] INFO: Deploying web application archive
>>> site.war[WARNING] [talledLocalContainer] Feb 14, 2013 4:20:26 PM
>>> org.apache.catalina.realm.JAASRealm setUseContextClassLoader[WARNING]
>>> [talledLocalContainer] INFO: Setting useContextClassLoader =
>>> true[WARNING]
>>> [talledLocalContainer] Feb 14, 2013 4:20:36 PM
>>> org.apache.catalina.startup.HostConfig deployDirectory[WARNING]
>>> [talledLocalContainer] INFO: Deploying web application directory
>>> host-manager[WARNING] [talledLocalContainer] Feb 14, 2013 4:20:36 PM
>>> org.apache.catalina.startup.HostConfig deployDirectory[WARNING]
>>> [talledLocalContainer] INFO: Deploying web application directory
>>> manager[WARNING] [talledLocalContainer] Feb 14, 2013 4:20:36 PM
>>> org.apache.coyote.http11.Http11Protocol start[WARNING]
>>> [talledLocalContainer] INFO: Starting Coyote HTTP/1.1 on
>>> http-8080[WARNING]
>>> [talledLocalContainer] Feb 14, 2013 4:20:36 PM
>>> org.apache.jk.common.ChannelSocket init[WARNING] [talledLocalContainer]
>>> INFO: JK: ajp13 listening on /0.0.0.0:8009[WARNING]
>>> [talledLocalContainer]
>>> Feb 14, 2013 4:20:36 PM org.apache.jk.server.JkMain start[WARNING]
>>> [talledLocalContainer] INFO: Jk running ID=0 time=0/42
>>> config=null[WARNING]
>>> [talledLocalContainer] Feb 14, 2013 4:20:36 PM
>>> org.apache.catalina.startup.Catalina start[WARNING]
>>> [talledLocalContainer]
>>> INFO: Server startup in 80814 ms[INFO] [talledLocalContainer] Tomcat 6.x
>>> started on port [8080][INFO] Press Ctrl-C to stop the container...[INFO]
>>> [talledLocalContainer] 14.02.2013 16:20:57 WARN
>>> [org.hippoecm.hst.container.HstFilter.doFilter():435]
>>> org.hippoecm.hst.core.container.RepositoryNotAvailableException for
>>> '/site/':
>>> 'org.hippoecm.hst.core.container.RepositoryNotAvailableException:
>>> Exception during loading configuration nodes. '
>>>
>>>
>>>
>>> --
>>> View this message in context:
>>> http://hippo.2275632.n2.nabble.com/RepositoryNotAvailableException-for-site-org-hippoecm-hst-core-container-tp7580435.html
>>> Sent from the Hippo CMS 7 mailing list archive at Nabble.com.
>>> _______________________________________________
>>> Hippo-cms7-user mailing list and forums
>>> http://www.onehippo.org/cms7/support/forums.html
>>
>>
>>
>> --
>> Jeroen Reijn
>> Solution Architect
>> Hippo
>>
>> Amsterdam - Oosteinde 11, 1017 WT Amsterdam
>> Boston - 1 Broadway, Cambridge, MA 02142
>>
>> US +1 877 414 4776 (toll free)
>> Europe +31(0)20 522 4466
>> www.onehippo.com
>>
>> http://about.me/jeroenreijn
>> _______________________________________________
>> Hippo-cms7-user mailing list and forums
>> http://www.onehippo.org/cms7/support/forums.html
>
>
>
> --
> Amsterdam - Oosteinde 11, 1017 WT Amsterdam
> Boston - 1 Broadway, Cambridge, MA 02142
>
> US +1 877 414 4776 (toll free)
> Europe +31(0)20 522 4466
> www.onehippo.com
> _______________________________________________
> Hippo-cms7-user mailing list and forums
> http://www.onehippo.org/cms7/support/forums.html
>
>
> ________________________________
> If you reply to this email, your message will be added to the discussion
> below:
> http://hippo.2275632.n2.nabble.com/RepositoryNotAvailableException-for-site-org-hippoecm-hst-core-container-tp7580435p7580440.html
> To unsubscribe from .RepositoryNotAvailableException for '/site/':
> 'org.hippoecm.hst.core.container., click here.
> NAML
Reply | Threaded
Open this post in threaded view
|

Re: .RepositoryNotAvailableException for '/site/': 'org.hippoecm.hst.core.container.

Michiel Rop
Hi,

Just a shot in the air: 

Did you by any chance use reload on startup on some namespaces, but not on the cnd ? 

In that case add a reload on startup on your cnd too.

Not adding it can give a RepositoryException too.


On Fri, Feb 15, 2013 at 7:24 AM, abhishek bhardwaj <[hidden email]> wrote:
Hi all,

I tried according to above solutions but still problem is not fix.
/cms is working
/cms/console is working
but /site is not going to open showing http 500 error.....



On Thu, Feb 14, 2013 at 6:01 PM, Ard [via Hippo]
<[hidden email]> wrote:
> in the 7.7 the RepositoryNotAvailableExcepton can be a bit confusing :
> In the 7.8 we have dropped this exception altogether.
>
> You get the RepositoryNotAvailableExcepton when the hstconfiguser
> cannot login into the repository. In the 7.8 you see a clean warning
> about a login exception.
>
> Either way, check your users/passwords in the hst-config,properties to
> be correct
>
> Regards Ard
>
> On Thu, Feb 14, 2013 at 1:10 PM, Jeroen Reijn <[hidden email]> wrote:
>
>> Well it says "Exception during loading configuration nodes", so I
>> guess you will need to check our HST configuration. Does it give more
>> hints in the hippo-site.log?
>>
>> On Thu, Feb 14, 2013 at 12:15 PM, abhishek bhardwaj
>> <[hidden email]> wrote:
>>> Hi allI am facing following problem while running  project on my
>>> machine.due
>>> to this cms and cms/consolo are working but /site is not working ......it
>>> shows http 500 error.i am attaching to you following snaps.es\Apache
>>> Software Foundation\apache-maven-3.0.4\bin[WARNING]
>>> [talledLocalContainer]
>>> Feb 14, 2013 4:19:15 PM org.apache.coyote.http11.Http11Protocol
>>> init[WARNING] [talledLocalContainer] INFO: Initializing Coyote HTTP/1.1
>>> on
>>> http-8080[WARNING] [talledLocalContainer] Feb 14, 2013 4:19:15 PM
>>> org.apache.catalina.startup.Catalina load[WARNING] [talledLocalContainer]
>>> INFO: Initialization processed in 965 ms[WARNING] [talledLocalContainer]
>>> Feb
>>> 14, 2013 4:19:15 PM org.apache.catalina.core.StandardService
>>> start[WARNING]
>>> [talledLocalContainer] INFO: Starting service Catalina[WARNING]
>>> [talledLocalContainer] Feb 14, 2013 4:19:15 PM
>>> org.apache.catalina.core.StandardEngine start[WARNING]
>>> [talledLocalContainer] INFO: Starting Servlet Engine: Apache
>>> Tomcat/6.0.35[WARNING] [talledLocalContainer] Feb 14, 2013 4:19:16 PM
>>> org.apache.catalina.startup.HostConfig deployWAR[WARNING]
>>> [talledLocalContainer] INFO: Deploying web application archive
>>> cargocpc.war[WARNING] [talledLocalContainer] Feb 14, 2013 4:19:16 PM
>>> org.apache.catalina.startup.HostConfig deployWAR[WARNING]
>>> [talledLocalContainer] INFO: Deploying web application archive
>>> cms.war[INFO]
>>> [talledLocalContainer] 14.02.2013 16:19:57 INFO
>>> [org.hippoecm.repository.updater.UpdaterEngine.migrate():629] no
>>> migration
>>> cycle because clean repository startup without hippo
>>> configuration[WARNING]
>>> [talledLocalContainer] Feb 14, 2013 4:20:26 PM
>>> org.apache.catalina.startup.HostConfig deployWAR[WARNING]
>>> [talledLocalContainer] INFO: Deploying web application archive
>>> site.war[WARNING] [talledLocalContainer] Feb 14, 2013 4:20:26 PM
>>> org.apache.catalina.realm.JAASRealm setUseContextClassLoader[WARNING]
>>> [talledLocalContainer] INFO: Setting useContextClassLoader =
>>> true[WARNING]
>>> [talledLocalContainer] Feb 14, 2013 4:20:36 PM
>>> org.apache.catalina.startup.HostConfig deployDirectory[WARNING]
>>> [talledLocalContainer] INFO: Deploying web application directory
>>> host-manager[WARNING] [talledLocalContainer] Feb 14, 2013 4:20:36 PM
>>> org.apache.catalina.startup.HostConfig deployDirectory[WARNING]
>>> [talledLocalContainer] INFO: Deploying web application directory
>>> manager[WARNING] [talledLocalContainer] Feb 14, 2013 4:20:36 PM
>>> org.apache.coyote.http11.Http11Protocol start[WARNING]
>>> [talledLocalContainer] INFO: Starting Coyote HTTP/1.1 on
>>> http-8080[WARNING]
>>> [talledLocalContainer] Feb 14, 2013 4:20:36 PM
>>> org.apache.jk.common.ChannelSocket init[WARNING] [talledLocalContainer]
>>> INFO: JK: ajp13 listening on /0.0.0.0:8009[WARNING]
>>> [talledLocalContainer]
>>> Feb 14, 2013 4:20:36 PM org.apache.jk.server.JkMain start[WARNING]
>>> [talledLocalContainer] INFO: Jk running ID=0 time=0/42
>>> config=null[WARNING]
>>> [talledLocalContainer] Feb 14, 2013 4:20:36 PM
>>> org.apache.catalina.startup.Catalina start[WARNING]
>>> [talledLocalContainer]
>>> INFO: Server startup in 80814 ms[INFO] [talledLocalContainer] Tomcat 6.x
>>> started on port [8080][INFO] Press Ctrl-C to stop the container...[INFO]
>>> [talledLocalContainer] 14.02.2013 16:20:57 WARN
>>> [org.hippoecm.hst.container.HstFilter.doFilter():435]
>>> org.hippoecm.hst.core.container.RepositoryNotAvailableException for
>>> '/site/':
>>> 'org.hippoecm.hst.core.container.RepositoryNotAvailableException:
>>> Exception during loading configuration nodes. '
>>>
>>>
>>>
>>> --
>>> View this message in context:
>>> http://hippo.2275632.n2.nabble.com/RepositoryNotAvailableException-for-site-org-hippoecm-hst-core-container-tp7580435.html
>>> Sent from the Hippo CMS 7 mailing list archive at Nabble.com.
>>> _______________________________________________
>>> Hippo-cms7-user mailing list and forums
>>> http://www.onehippo.org/cms7/support/forums.html
>>
>>
>>
>> --
>> Jeroen Reijn
>> Solution Architect
>> Hippo
>>
>> Amsterdam - Oosteinde 11, 1017 WT Amsterdam
>> Boston - 1 Broadway, Cambridge, MA 02142
>>
>> US <a href="tel:%2B1%20877%20414%204776" value="+18774144776">+1 877 414 4776 (toll free)
>> Europe <a href="tel:%2B31%280%2920%20522%204466" value="+31205224466">+31(0)20 522 4466
>> www.onehippo.com
>>
>> http://about.me/jeroenreijn
>> _______________________________________________
>> Hippo-cms7-user mailing list and forums
>> http://www.onehippo.org/cms7/support/forums.html
>
>
>
> --
> Amsterdam - Oosteinde 11, 1017 WT Amsterdam
> Boston - 1 Broadway, Cambridge, MA 02142
>
> US <a href="tel:%2B1%20877%20414%204776" value="+18774144776">+1 877 414 4776 (toll free)
> Europe <a href="tel:%2B31%280%2920%20522%204466" value="+31205224466">+31(0)20 522 4466
> www.onehippo.com
> _______________________________________________
> Hippo-cms7-user mailing list and forums
> http://www.onehippo.org/cms7/support/forums.html
>
>
> ________________________________
> If you reply to this email, your message will be added to the discussion
> below:
> http://hippo.2275632.n2.nabble.com/RepositoryNotAvailableException-for-site-org-hippoecm-hst-core-container-tp7580435p7580440.html
> To unsubscribe from .RepositoryNotAvailableException for '/site/':
> 'org.hippoecm.hst.core.container., click here.
> NAML




--
View this message in context: http://hippo.2275632.n2.nabble.com/RepositoryNotAvailableException-for-site-org-hippoecm-hst-core-container-tp7580435p7580447.html
Sent from the Hippo CMS 7 mailing list archive at Nabble.com.
_______________________________________________
Hippo-cms7-user mailing list and forums
http://www.onehippo.org/cms7/support/forums.html



--
Met vriendelijke groet, / Best regards,
Michiel Rop
+31 (0)6 5279 2264

--
Amsterdam - Oosteinde 11, 1017 WT Amsterdam
Boston - 1 Broadway, Cambridge, MA 02142

US +1 877 414 4776 (toll free)
Europe +31(0)20 522 4466
www.onehippo.com

_______________________________________________
Hippo-cms7-user mailing list and forums
http://www.onehippo.org/cms7/support/forums.html
Ard
Reply | Threaded
Open this post in threaded view
|

Re: .RepositoryNotAvailableException for '/site/': 'org.hippoecm.hst.core.container.

Ard
In reply to this post by abhishek bhardwaj


Op 15 feb. 2013 07:25 schreef "abhishek bhardwaj" <[hidden email]> het volgende:
>
> Hi all,
>
> I tried according to above solutions but still problem is not fix.
> /cms is working
> /cms/console is working
> but /site is not going to open showing http 500 error.....
>

You can set log level to debug or add a breakpoint in hstmanagerimpl to see when it goes wrong. Also check whether with the hstconfig user you can login to the repositoryservlet. I still bet your credentials are incorrect.

Otherwise contact sales to get hippo support. As said already, we cannot invest endless support on this list.

Regards ard

>
>
> On Thu, Feb 14, 2013 at 6:01 PM, Ard [via Hippo]
> <[hidden email]> wrote:
> > in the 7.7 the RepositoryNotAvailableExcepton can be a bit confusing :
> > In the 7.8 we have dropped this exception altogether.
> >
> > You get the RepositoryNotAvailableExcepton when the hstconfiguser
> > cannot login into the repository. In the 7.8 you see a clean warning
> > about a login exception.
> >
> > Either way, check your users/passwords in the hst-config,properties to
> > be correct
> >
> > Regards Ard
> >
> > On Thu, Feb 14, 2013 at 1:10 PM, Jeroen Reijn <[hidden email]> wrote:
> >
> >> Well it says "Exception during loading configuration nodes", so I
> >> guess you will need to check our HST configuration. Does it give more
> >> hints in the hippo-site.log?
> >>
> >> On Thu, Feb 14, 2013 at 12:15 PM, abhishek bhardwaj
> >> <[hidden email]> wrote:
> >>> Hi allI am facing following problem while running  project on my
> >>> machine.due
> >>> to this cms and cms/consolo are working but /site is not working ......it
> >>> shows http 500 error.i am attaching to you following snaps.es\Apache
> >>> Software Foundation\apache-maven-3.0.4\bin[WARNING]
> >>> [talledLocalContainer]
> >>> Feb 14, 2013 4:19:15 PM org.apache.coyote.http11.Http11Protocol
> >>> init[WARNING] [talledLocalContainer] INFO: Initializing Coyote HTTP/1.1
> >>> on
> >>> http-8080[WARNING] [talledLocalContainer] Feb 14, 2013 4:19:15 PM
> >>> org.apache.catalina.startup.Catalina load[WARNING] [talledLocalContainer]
> >>> INFO: Initialization processed in 965 ms[WARNING] [talledLocalContainer]
> >>> Feb
> >>> 14, 2013 4:19:15 PM org.apache.catalina.core.StandardService
> >>> start[WARNING]
> >>> [talledLocalContainer] INFO: Starting service Catalina[WARNING]
> >>> [talledLocalContainer] Feb 14, 2013 4:19:15 PM
> >>> org.apache.catalina.core.StandardEngine start[WARNING]
> >>> [talledLocalContainer] INFO: Starting Servlet Engine: Apache
> >>> Tomcat/6.0.35[WARNING] [talledLocalContainer] Feb 14, 2013 4:19:16 PM
> >>> org.apache.catalina.startup.HostConfig deployWAR[WARNING]
> >>> [talledLocalContainer] INFO: Deploying web application archive
> >>> cargocpc.war[WARNING] [talledLocalContainer] Feb 14, 2013 4:19:16 PM
> >>> org.apache.catalina.startup.HostConfig deployWAR[WARNING]
> >>> [talledLocalContainer] INFO: Deploying web application archive
> >>> cms.war[INFO]
> >>> [talledLocalContainer] 14.02.2013 16:19:57 INFO
> >>> [org.hippoecm.repository.updater.UpdaterEngine.migrate():629] no
> >>> migration
> >>> cycle because clean repository startup without hippo
> >>> configuration[WARNING]
> >>> [talledLocalContainer] Feb 14, 2013 4:20:26 PM
> >>> org.apache.catalina.startup.HostConfig deployWAR[WARNING]
> >>> [talledLocalContainer] INFO: Deploying web application archive
> >>> site.war[WARNING] [talledLocalContainer] Feb 14, 2013 4:20:26 PM
> >>> org.apache.catalina.realm.JAASRealm setUseContextClassLoader[WARNING]
> >>> [talledLocalContainer] INFO: Setting useContextClassLoader =
> >>> true[WARNING]
> >>> [talledLocalContainer] Feb 14, 2013 4:20:36 PM
> >>> org.apache.catalina.startup.HostConfig deployDirectory[WARNING]
> >>> [talledLocalContainer] INFO: Deploying web application directory
> >>> host-manager[WARNING] [talledLocalContainer] Feb 14, 2013 4:20:36 PM
> >>> org.apache.catalina.startup.HostConfig deployDirectory[WARNING]
> >>> [talledLocalContainer] INFO: Deploying web application directory
> >>> manager[WARNING] [talledLocalContainer] Feb 14, 2013 4:20:36 PM
> >>> org.apache.coyote.http11.Http11Protocol start[WARNING]
> >>> [talledLocalContainer] INFO: Starting Coyote HTTP/1.1 on
> >>> http-8080[WARNING]
> >>> [talledLocalContainer] Feb 14, 2013 4:20:36 PM
> >>> org.apache.jk.common.ChannelSocket init[WARNING] [talledLocalContainer]
> >>> INFO: JK: ajp13 listening on /0.0.0.0:8009[WARNING]
> >>> [talledLocalContainer]
> >>> Feb 14, 2013 4:20:36 PM org.apache.jk.server.JkMain start[WARNING]
> >>> [talledLocalContainer] INFO: Jk running ID=0 time=0/42
> >>> config=null[WARNING]
> >>> [talledLocalContainer] Feb 14, 2013 4:20:36 PM
> >>> org.apache.catalina.startup.Catalina start[WARNING]
> >>> [talledLocalContainer]
> >>> INFO: Server startup in 80814 ms[INFO] [talledLocalContainer] Tomcat 6.x
> >>> started on port [8080][INFO] Press Ctrl-C to stop the container...[INFO]
> >>> [talledLocalContainer] 14.02.2013 16:20:57 WARN
> >>> [org.hippoecm.hst.container.HstFilter.doFilter():435]
> >>> org.hippoecm.hst.core.container.RepositoryNotAvailableException for
> >>> '/site/':
> >>> 'org.hippoecm.hst.core.container.RepositoryNotAvailableException:
> >>> Exception during loading configuration nodes. '
> >>>
> >>>
> >>>
> >>> --
> >>> View this message in context:
> >>> http://hippo.2275632.n2.nabble.com/RepositoryNotAvailableException-for-site-org-hippoecm-hst-core-container-tp7580435.html
> >>> Sent from the Hippo CMS 7 mailing list archive at Nabble.com.
> >>> _______________________________________________
> >>> Hippo-cms7-user mailing list and forums
> >>> http://www.onehippo.org/cms7/support/forums.html
> >>
> >>
> >>
> >> --
> >> Jeroen Reijn
> >> Solution Architect
> >> Hippo
> >>
> >> Amsterdam - Oosteinde 11, 1017 WT Amsterdam
> >> Boston - 1 Broadway, Cambridge, MA 02142
> >>
> >> US +1 877 414 4776 (toll free)
> >> Europe +31(0)20 522 4466
> >> www.onehippo.com
> >>
> >> http://about.me/jeroenreijn
> >> _______________________________________________
> >> Hippo-cms7-user mailing list and forums
> >> http://www.onehippo.org/cms7/support/forums.html
> >
> >
> >
> > --
> > Amsterdam - Oosteinde 11, 1017 WT Amsterdam
> > Boston - 1 Broadway, Cambridge, MA 02142
> >
> > US +1 877 414 4776 (toll free)
> > Europe +31(0)20 522 4466
> > www.onehippo.com
> > _______________________________________________
> > Hippo-cms7-user mailing list and forums
> > http://www.onehippo.org/cms7/support/forums.html
> >
> >
> > ________________________________
> > If you reply to this email, your message will be added to the discussion
> > below:
> > http://hippo.2275632.n2.nabble.com/RepositoryNotAvailableException-for-site-org-hippoecm-hst-core-container-tp7580435p7580440.html
> > To unsubscribe from .RepositoryNotAvailableException for '/site/':
> > 'org.hippoecm.hst.core.container., click here.
> > NAML
>
>
>
>
> --
> View this message in context: http://hippo.2275632.n2.nabble.com/RepositoryNotAvailableException-for-site-org-hippoecm-hst-core-container-tp7580435p7580447.html
> Sent from the Hippo CMS 7 mailing list archive at Nabble.com.
> _______________________________________________
> Hippo-cms7-user mailing list and forums
> http://www.onehippo.org/cms7/support/forums.html


_______________________________________________
Hippo-cms7-user mailing list and forums
http://www.onehippo.org/cms7/support/forums.html