install-demo.html

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

install-demo.html

tommi.lukkarinen
Hi,

I tried the demo with installer, and plan to try with building from source
next, but I would like to get this installer demo working properly first to
see I am on the right track.

I have the repository and tomcat started, but

1. I cant get into http://intranet.localhost:8080/demo-portal/
 - HTTP Status 404 - No page matched / request in site view.

2. Demo misses most of the Jetspeed 2 features like breadcrumbs, folders,
etc. I added an image. It seems there would be considerable effort to get
it into same level as the current Jetspeed 2 demo, and would the Hippo CMS
support all those features?

Finally, the startup logs, I did not see anything alarming here myself:

C:\demo\hippo-repository-1.2.11\bin>wrapper -c wrapper.conf
2009/11/26 08:55:12 | STATUS | wrapper  | --> Wrapper Started as Console
2009/11/26 08:55:12 | STATUS | wrapper  | Launching a JVM...
2009/11/26 08:55:14 | INFO   | jvm 1    | Wrapper (Version 3.1.2)
http://wrapper.tanukisoftware.org
2009/11/26 08:55:14 | INFO   | jvm 1    |
2009/11/26 08:55:14 | INFO   | jvm 1    | Starting Fortress
2009/11/26 08:55:15 | INFO   | jvm 1    | OpenJMS 0.7.6.1
2009/11/26 08:55:15 | INFO   | jvm 1    | The OpenJMS Group. (C)
1999-2004. All rights reserved.
2009/11/26 08:55:15 | INFO   | jvm 1    | http://openjms.sourceforge.net
2009/11/26 08:55:19 | INFO   | jvm 1    | Fortress started

-----

:\Program Files\QuickTime\QTSystem\;C:\Program
Files\TortoiseSVN\bin;C:\code\SDK\bin
Nov 26, 2009 9:42:13 AM org.apache.coyote.http11.Http11BaseProtocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
Nov 26, 2009 9:42:13 AM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 938 ms
Nov 26, 2009 9:42:13 AM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Nov 26, 2009 9:42:13 AM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/5.5.20
Nov 26, 2009 9:42:13 AM org.apache.catalina.core.StandardHost start
INFO: XML validation disabled
Nov 26, 2009 9:42:14 AM org.apache.catalina.startup.HostConfig
deployDescriptor
WARNING: A docBase C:\demo\hippo-portal\webapps\demo-portal inside the
host appBase has been specified, and will be ignored
Nov 26, 2009 9:42:14 AM org.apache.catalina.realm.JAASRealm
setUseContextClassLoader
INFO: Setting useContextClassLoader = false
log4j:WARN No appenders could be found for logger
(org.apache.commons.digester.Digester.sax).
log4j:WARN Please initialize the log4j system properly.
Nov 26, 2009 9:42:15 AM org.apache.catalina.startup.ContextConfig
validateSecurityRoles
INFO: WARNING: Security role name portal-user used in an <auth-constraint>
without being defined in a <security-role>
Nov 26, 2009 9:42:15 AM org.apache.catalina.startup.ContextConfig
validateSecurityRoles
INFO: WARNING: Security role name admin used in an <auth-constraint>
without being defined in a <security-role>
##### platform = Hsqldb
 WARN: org.apache.pluto.PortletContainerImpl#init(): Couldn't retrieve
parameter "portletcontainer.supportsBuffering" frompassed properties
object. Falling back
 to default value "FALSE"
Nov 26, 2009 9:42:32 AM org.apache.catalina.startup.HostConfig deployWAR
INFO: Deploying web application archive hippo-portal.war
log4j:WARN No appenders could be found for logger
(org.apache.commons.digester.Digester.sax).
log4j:WARN Please initialize the log4j system properly.
Nov 26, 2009 9:42:35 AM org.apache.catalina.startup.HostConfig deployWAR
INFO: Deploying web application archive demo-pa.war
log4j:WARN No appenders could be found for logger
(org.apache.commons.digester.Digester.sax).
log4j:WARN Please initialize the log4j system properly.
JetspeedContainerServlet: starting initialization of Portlet Application
at: demo-pa
JetspeedContainerServlet: initialization done for Portlet Application at:
demo-pa
Nov 26, 2009 9:42:39 AM org.apache.coyote.http11.Http11BaseProtocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
Nov 26, 2009 9:42:39 AM org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8009
Nov 26, 2009 9:42:39 AM org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/62  config=null
Nov 26, 2009 9:42:39 AM org.apache.catalina.storeconfig.StoreLoader load
INFO: Find registry server-registry.xml at classpath resource
Nov 26, 2009 9:42:39 AM org.apache.catalina.startup.Catalina start
INFO: Server startup in 26391 ms





_______________________________________________
Hippoportal-dev mailing list
[hidden email]
http://lists.hippo.nl/mailman/listinfo/hippoportal-dev

portalpage.PNG (54K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: install-demo.html

Ate Douma-3
Hi Tommi,

See my comments below.

Regards,

Ate

[hidden email] wrote:

> Hi,
>
> I tried the demo with installer, and plan to try with building from source
> next, but I would like to get this installer demo working properly first to
> see I am on the right track.
>
> I have the repository and tomcat started, but
>
> 1. I cant get into http://intranet.localhost:8080/demo-portal/
>  - HTTP Status 404 - No page matched / request in site view.
You also attached a screenshot which shows using that domain and path, so it seems you're no longer having this problem?
One thing to make sure is that your machine is mapped to intranet.localhost in your hosts file.

>
> 2. Demo misses most of the Jetspeed 2 features like breadcrumbs, folders,
> etc. I added an image. It seems there would be considerable effort to get
> it into same level as the current Jetspeed 2 demo, and would the Hippo CMS
> support all those features?
Hippo Portal 1.x provides something we call a "virtualized" site, meaning that the url -> page mapping is managed and controlled by the
Hippo Portal extensions which use Hippo Repository based configuration.
The standard Jetspeed-2 site features like breadcrumbs, menus, folders etc. are managed differently, through the JetspeedProfiler.
It is possible to mix using both Jetspeed-2 and Hippo Portal "site" features, but in this 1.x version of Hippo Portal you can't really mix
them together on the same "site" or sub path.
For the Hippo Portal demo we stripped out most of the default Jetspeed 2 site features to provide a simple starting point for the Hippo
Portal site feature. So you can't use the *demo* installer to access the Jetspeed 2 site features but will have to create a custom Hippo
Portal project yourself to bring those back (or not strip them out).

For Hippo Portal 2.x, which will use Hippo Repository 2 (JCR), Hippo CMS 7 and Jetspeed 2.2.x, we're working on transparent merging of the
two solutions.


>
> Finally, the startup logs, I did not see anything alarming here myself:
>
> C:\demo\hippo-repository-1.2.11\bin>wrapper -c wrapper.conf
> 2009/11/26 08:55:12 | STATUS | wrapper  | --> Wrapper Started as Console
> 2009/11/26 08:55:12 | STATUS | wrapper  | Launching a JVM...
> 2009/11/26 08:55:14 | INFO   | jvm 1    | Wrapper (Version 3.1.2)
> http://wrapper.tanukisoftware.org
> 2009/11/26 08:55:14 | INFO   | jvm 1    |
> 2009/11/26 08:55:14 | INFO   | jvm 1    | Starting Fortress
> 2009/11/26 08:55:15 | INFO   | jvm 1    | OpenJMS 0.7.6.1
> 2009/11/26 08:55:15 | INFO   | jvm 1    | The OpenJMS Group. (C)
> 1999-2004. All rights reserved.
> 2009/11/26 08:55:15 | INFO   | jvm 1    | http://openjms.sourceforge.net
> 2009/11/26 08:55:19 | INFO   | jvm 1    | Fortress started
>
> -----
>
> :\Program Files\QuickTime\QTSystem\;C:\Program
> Files\TortoiseSVN\bin;C:\code\SDK\bin
> Nov 26, 2009 9:42:13 AM org.apache.coyote.http11.Http11BaseProtocol init
> INFO: Initializing Coyote HTTP/1.1 on http-8080
> Nov 26, 2009 9:42:13 AM org.apache.catalina.startup.Catalina load
> INFO: Initialization processed in 938 ms
> Nov 26, 2009 9:42:13 AM org.apache.catalina.core.StandardService start
> INFO: Starting service Catalina
> Nov 26, 2009 9:42:13 AM org.apache.catalina.core.StandardEngine start
> INFO: Starting Servlet Engine: Apache Tomcat/5.5.20
> Nov 26, 2009 9:42:13 AM org.apache.catalina.core.StandardHost start
> INFO: XML validation disabled
> Nov 26, 2009 9:42:14 AM org.apache.catalina.startup.HostConfig
> deployDescriptor
> WARNING: A docBase C:\demo\hippo-portal\webapps\demo-portal inside the
> host appBase has been specified, and will be ignored
> Nov 26, 2009 9:42:14 AM org.apache.catalina.realm.JAASRealm
> setUseContextClassLoader
> INFO: Setting useContextClassLoader = false
> log4j:WARN No appenders could be found for logger
> (org.apache.commons.digester.Digester.sax).
> log4j:WARN Please initialize the log4j system properly.
> Nov 26, 2009 9:42:15 AM org.apache.catalina.startup.ContextConfig
> validateSecurityRoles
> INFO: WARNING: Security role name portal-user used in an <auth-constraint>
> without being defined in a <security-role>
> Nov 26, 2009 9:42:15 AM org.apache.catalina.startup.ContextConfig
> validateSecurityRoles
> INFO: WARNING: Security role name admin used in an <auth-constraint>
> without being defined in a <security-role>
> ##### platform = Hsqldb
>  WARN: org.apache.pluto.PortletContainerImpl#init(): Couldn't retrieve
> parameter "portletcontainer.supportsBuffering" frompassed properties
> object. Falling back
>  to default value "FALSE"
> Nov 26, 2009 9:42:32 AM org.apache.catalina.startup.HostConfig deployWAR
> INFO: Deploying web application archive hippo-portal.war
> log4j:WARN No appenders could be found for logger
> (org.apache.commons.digester.Digester.sax).
> log4j:WARN Please initialize the log4j system properly.
> Nov 26, 2009 9:42:35 AM org.apache.catalina.startup.HostConfig deployWAR
> INFO: Deploying web application archive demo-pa.war
> log4j:WARN No appenders could be found for logger
> (org.apache.commons.digester.Digester.sax).
> log4j:WARN Please initialize the log4j system properly.
> JetspeedContainerServlet: starting initialization of Portlet Application
> at: demo-pa
> JetspeedContainerServlet: initialization done for Portlet Application at:
> demo-pa
> Nov 26, 2009 9:42:39 AM org.apache.coyote.http11.Http11BaseProtocol start
> INFO: Starting Coyote HTTP/1.1 on http-8080
> Nov 26, 2009 9:42:39 AM org.apache.jk.common.ChannelSocket init
> INFO: JK: ajp13 listening on /0.0.0.0:8009
> Nov 26, 2009 9:42:39 AM org.apache.jk.server.JkMain start
> INFO: Jk running ID=0 time=0/62  config=null
> Nov 26, 2009 9:42:39 AM org.apache.catalina.storeconfig.StoreLoader load
> INFO: Find registry server-registry.xml at classpath resource
> Nov 26, 2009 9:42:39 AM org.apache.catalina.startup.Catalina start
> INFO: Server startup in 26391 ms
>
>
>
>
>
>
> ------------------------------------------------------------------------
>
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> Hippoportal-dev mailing list
> [hidden email]
> http://lists.hippo.nl/mailman/listinfo/hippoportal-dev


--
[hidden email]  www.onehippo.com

Amsterdam     - Hippo B.V. Oosteinde 11 1017 WT Amsterdam +31(0)20-5224466
San Francisco - Hippo USA Inc. 101 H Street, suite Q Petaluma CA 94952-5100 +1(877) 41-HIPPO

_______________________________________________
Hippoportal-dev mailing list
[hidden email]
http://lists.hippo.nl/mailman/listinfo/hippoportal-dev